Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen im Patrizierforum. Falls dies Dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird Dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest Du Dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um Dich zu registrieren oder informiere Dich ausführlich über den Registrierungsvorgang. Falls Du Dich bereits zu einem früheren Zeitpunkt registriert hast, kannst Du Dich hier anmelden.

hase09127

Schniggenfahrer

  • »hase09127« ist der Autor dieses Themas

Beiträge: 36

Dabei seit: 21. Juli 2015

Wohnort: Frankreich

  • Private Nachricht senden

1

Dienstag, 21. Juli 2015, 18:22

Spielabsturz unter Win8.1

Hallo an alle,

ich weiss echt nicht mehr weiter, ich habe mir vor 10 Monaten einen neuen PC gekauft, aber jedes Mal wenn ich P4 spiele, stürzt mir das Spiel ab (manchmal erst nach ein paar Stunden, manchmal nach ein paar Minuten - Fehlermeldung P4 reagiert nicht mehr) oder ich habe einen blauen Bildschirm mit Hintergrundmusik.

Mein Betriebssystem ist Windows 8.1 auf französisch, der Fehler im Ereignisbeobachter hilft mir auch nicht wirklich weiter

"Nom de l’application défaillante Patrician4_addon.exe, version : 2.0.4.0, horodatage : 0x4e5e1d42
Nom du module défaillant : Patrician4_addon.exe, version : 2.0.4.0, horodatage : 0x4e5e1d42
Code d’exception : 0xc0000005
Décalage d’erreur : 0x0037a420
ID du processus défaillant : 0x5c0
Heure de début de l’application défaillante : 0x01d0c3cd6a28a81d
Chemin d’accès de l’application défaillante : C:\Program Files (x86)\Jeux\Patrician IV Gold Edition\Patrician4_addon.exe
Chemin d’accès du module défaillant: C:\Program Files (x86)\Jeux\Patrician IV Gold Edition\Patrician4_addon.exe
ID de rapport : 7cdb84dd-2fc2-11e5-82d9-9cad97ce0f74
Nom complet du package défaillant :
ID de l’application relative au package défaillant : "


Mit meinem vorherigen PC hatte ich dieses Problem nicht, jedoch konnte ich das Spiel nicht spielen, weil meine Grafikkarte und RAM zu schwach war.

Da ich dieses Spiel schon seit P1 kenne und liebe, macht es mich umso trauriger P4 nicht spielen zu können.

Hat jemand eine Ahnung woran das liegen kann ?

2

Dienstag, 21. Juli 2015, 20:47

Moin hase09127,

Herzlich Willkommen im Forum!

Ist so eine Sache mit Win8.1, da bei Entwicklung von P4 selbst Win7 gerade erst in den Startlöchern stand.
Hast Du mal versucht, P4 mit Kompatibilitätsmodus zu Win7 oder XP auszuführen (siehe auch >hier< oder >hier<)?
Ansonsten könnte eventuell eine DxDiag von Deinem System Aufschluss geben, wenn Du sie hier einstellen magst.

Gruß
Cete

hase09127

Schniggenfahrer

  • »hase09127« ist der Autor dieses Themas

Beiträge: 36

Dabei seit: 21. Juli 2015

Wohnort: Frankreich

  • Private Nachricht senden

3

Dienstag, 21. Juli 2015, 21:13

wie mach ich das mit dem dxdiag ?

selbst unter kompatibilitätsmodus spinnt es rum (daran hab ich sofort gedacht)

4

Dienstag, 21. Juli 2015, 21:53

Moin hase09127,

hab Dir mal unten ein zweiteiliges Bild (links, rechts) angehangen, wie man eine dxdiag.txt unter Win7 erzeugt, sollte unter Win8.1 ähnlich gehen.
1. Auf den Start-Button unten links klicken
2. In das Eingabefeld ganz unten links dxdiag eintippen (siehe Bild links, roter Rahmen unten) => die dxdiag.exe wird gefunden (siehe Bild links, roter Rahmen oben)
3. dxdiag.exe anklicken => das DirectX-Diagnoseprogramm öffnet sich
4. Warten bis alle Systemdaten geladen wurden (grüner Fortschrittsbalken unten links - verschwindet, wenn fertig)
5. Auf "Alle Informationen speichern" klicken => ein Fenster wird geöffnet, in dem Du angibst, wo die dxdiag.txt gespeichert werden soll (Verzeichnis merken!)
6. Die dxdiag.txt suchen und hier an Deine Antwort hängen

Datei an Deine Antwort hängen:
1. Deinen Antwort-Text schreiben
2. Unter dem Text-Editor auf den Reiter "Dateianhänge" klicken
3. Auf "Durchsuchen" klicken
4. Das gemerkte Verzeichnis und anschließend die dxdiag.txt auswählen
5. Auf Hochladen klicken
6. Antwort absenden

Hoffentlich verständlich beschrieben, ansonsten frag einfach nochmal nach. ;)


Gruß
Cete
»Cete von Holstein« hat folgendes Bild angehängt:
  • dxdiag_pic.jpg

hase09127

Schniggenfahrer

  • »hase09127« ist der Autor dieses Themas

Beiträge: 36

Dabei seit: 21. Juli 2015

Wohnort: Frankreich

  • Private Nachricht senden

5

Dienstag, 21. Juli 2015, 23:41

so hier also nun das Ergebnis

und erst mal vielen Dank für die schnelle Hilfe
»hase09127« hat folgende Datei angehängt:
  • DxDiag.txt (100,1 kB - 286 mal heruntergeladen - zuletzt: Heute, 12:12)

Kalynorass

Eldermann

  • »Kalynorass« ist männlich
  • »Kalynorass« wurde gesperrt

Beiträge: 2 383

Dabei seit: 15. Juli 2007

Wohnort: Freie Hansestadt Bremen

  • Private Nachricht senden

6

Mittwoch, 22. Juli 2015, 01:19

Ahoi, Hase09127!

Versuch doch mal zum Test, dem Spiel weniger Kerne zuzuordnen, beginnend mit einem Kern.
--> Weg: Taskmanager öffnen, Kontextmenü des P4-Prozesses öffnen und "Zugehörigkeit festlegen" auswählen.

Daan Hugo

Kaufmann

  • »Daan Hugo« ist männlich

Beiträge: 208

Dabei seit: 28. Juni 2011

Wohnort: GMS-HQ

  • Private Nachricht senden

7

Mittwoch, 22. Juli 2015, 10:15

Hallo!

Meine Vermutung:
Das Spiel verwendet die Intel (Dedicated Memory: 0 MB) Grafikkarte statt der von nVidia.

Beste Grüße,
Daan

hase09127

Schniggenfahrer

  • »hase09127« ist der Autor dieses Themas

Beiträge: 36

Dabei seit: 21. Juli 2015

Wohnort: Frankreich

  • Private Nachricht senden

8

Mittwoch, 22. Juli 2015, 12:31

Daan : wie änder ich das mit der Grafikkarte ?

Kalnorass : wie mach ich das mit dem Kontextmenü (ich muss mir ja leider alles ins französische übersetzen)

Kalynorass

Eldermann

  • »Kalynorass« ist männlich
  • »Kalynorass« wurde gesperrt

Beiträge: 2 383

Dabei seit: 15. Juli 2007

Wohnort: Freie Hansestadt Bremen

  • Private Nachricht senden

9

Mittwoch, 22. Juli 2015, 13:57

Zwar vermute ich dringend, dass Daan mit seinem Tipp am Punkt ist, aber versuchen kannste das mit der Zuordnung der Kerne allemal -- es gibt auch andere Anwendungen, die mit Mehrkernern unter Win 8+ Probleme haben. Der Grund ist aber wohl generell der Umgang eines 64-Bit-Systems mit 32-Bit-Programmen.

Detaillierter dargestellt:

0.) Das betreffende Proggi - hier Patrizier 4 - starten.
1.) TASK MANAGER aufrufen (CTRL+Shift+ESC), den zweitrechten Reiter "Details" klicken (der vmtl. auch in Deinem franz. System so heißt *g*).
2.) Ganz Links unter den laufenden Prozessen P4 suchen und markieren (einmal mit Linker Maustaste anklicken): "Patrician4Gold.exe", es könnte bei Dir gaaaaanz u.U. irgendwas mit 'jeu' (frz. "Spiel") sein; nun Rechte Maustaste klicken und das Kontextmenü erscheint.
Dort müsstest Du etwas mit 'affiliation' (frz. "Zugehörigkeit") finden, anklicken.
3.) Jetzt taucht die Übersicht der CPUs auf; Du kannst festlegen, wie viele der Kerne im Spiel arbeiten sollen. Alle, einer/der erste ("0") oder mehrere Kerne.

Testweise würde ich - falls nicht schon anders eingestellt - die ersten beiden Kerne (also "0" und "1") es mal alleine versuchen lassen. Sollte das nicht klappen, einfach alles wieder auf die anfänglichen Einstellungen setzen.
Viel Glück!


Screenshot zur Hilfe

Links der Ablauf von einer Win-Hilfeseite bei Win 8.1, rechts meine Ansicht der Zugehörigkeitsbestimmung bei meinem Vierkerner (hier: unter Win7).
(*Klick* zum Vergrößern!)


hase09127

Schniggenfahrer

  • »hase09127« ist der Autor dieses Themas

Beiträge: 36

Dabei seit: 21. Juli 2015

Wohnort: Frankreich

  • Private Nachricht senden

10

Mittwoch, 22. Juli 2015, 14:28

ok ich werde schon mal das mit den Kernen versuchen, ich hatte bei meinem vorherigen PC mit den Kernen bei Sacred Multiplayer schon mal so ein Problem

ich halte euch auf dem Laufenden

hase09127

Schniggenfahrer

  • »hase09127« ist der Autor dieses Themas

Beiträge: 36

Dabei seit: 21. Juli 2015

Wohnort: Frankreich

  • Private Nachricht senden

11

Mittwoch, 22. Juli 2015, 15:24

kann man seine Beiträge editieren ??

also hab jetzt wie du vorgeschlagen hast nur Kerne 0 und 1 behalten, Spiel stürzt trotzdem ab... ich denke auch das es von der Grafikkarte kommt, nur hab ich keine Ahnung wie ich das ändern kann... :(

x9jaan

Administrator

  • »x9jaan« ist männlich

Beiträge: 3 574

Dabei seit: 17. Februar 2006

Wohnort: Schnellmannshausen

  • Private Nachricht senden

12

Mittwoch, 22. Juli 2015, 15:58

Beiträge editieren

Du kannst 30 Minuten lang deine Beiträge editieren. Danach ist Schluss. Wenn zwei Beiträge von dir untereinander stehen, macht das nichts.
Die Schatzkarten als *-zip-Datei.

Kalynorass

Eldermann

  • »Kalynorass« ist männlich
  • »Kalynorass« wurde gesperrt

Beiträge: 2 383

Dabei seit: 15. Juli 2007

Wohnort: Freie Hansestadt Bremen

  • Private Nachricht senden

13

Mittwoch, 22. Juli 2015, 17:09

Schau in den Gerätemanager (am besten über den Command-Prompt wie oben beim Erstellen der DivX-Diagnose) und gib dort devmgmt.msc ein.
Nun musst Du Dich zu den Grafikkarten hangeln, wo Du zwei Einträge finden solltest. Die "Nicht-Invidea" per Kontextmenü deaktivieren, bestätigen und PAT 4 testen.
Müsste klappen, wenn das wirklich das Problem ist.

hase09127

Schniggenfahrer

  • »hase09127« ist der Autor dieses Themas

Beiträge: 36

Dabei seit: 21. Juli 2015

Wohnort: Frankreich

  • Private Nachricht senden

14

Mittwoch, 22. Juli 2015, 17:32

hab grad die Intelkarte desaktiviert, jetzt ruckelt das Spiel beim spielen, alles ist verlangsamt und ich muss mehrmal auf etwas drücken, damit sich ein Fenster usw. öffnet :(
ich habe schon die Grafikoption auf schwach eingestellt, weil ich schon seit längerem die Grafikkarte hinter meinem Absturzproblemen vermutete ...

werde jedoch trotzdem testen ob das Spiel abstürzt oder nicht, ich halte euch auf dem Laufenden ... und falls jemand eine Idee gegen das ruckelartige spielen hat, nehme ich gerne entgegen

<--- hab grad in nem anderen Thread was darüber gelesen, mit der 3D Einstellung von NVIDIA, nur kann ich auf die NVIDIA Optionen nicht mehr zugreifen, solange die Intel HD Karte desaktiviert ist ... hmmm alles etwas seltsam


komischerweise bei Patrizier ohne Addon war die Grafikkarte die NVIDIA in den 3D Einstellungen, die Addon habe ich gerade hinzugefügt, ich teste das erstmal

Kalynorass

Eldermann

  • »Kalynorass« ist männlich
  • »Kalynorass« wurde gesperrt

Beiträge: 2 383

Dabei seit: 15. Juli 2007

Wohnort: Freie Hansestadt Bremen

  • Private Nachricht senden

15

Mittwoch, 22. Juli 2015, 17:42

Aber alle 4 Kerne arbeiten jetzt wieder, ja?
U.U. könnte es helfen, das Game neu zu installieren, weil das Setup womöglich der "falschen" GraKa gemäß eingerichtet wurde.

hase09127

Schniggenfahrer

  • »hase09127« ist der Autor dieses Themas

Beiträge: 36

Dabei seit: 21. Juli 2015

Wohnort: Frankreich

  • Private Nachricht senden

16

Mittwoch, 22. Juli 2015, 17:45

jedes Mal wenn das Spiel abstürzt bzw. wenn ich das Spiel neu starte, lädt er automatisch die 4 Kerne, er behält die 2 Kerne-Einstellungen nicht...


ich teste erstmal weiter und im schlimmsten Fall, werde ich alles desinstallieren und nur mit der Nvidia reinstallieren um zu testen

hase09127

Schniggenfahrer

  • »hase09127« ist der Autor dieses Themas

Beiträge: 36

Dabei seit: 21. Juli 2015

Wohnort: Frankreich

  • Private Nachricht senden

17

Donnerstag, 23. Juli 2015, 16:04

ok hab jetzt da mal ne runde getestet, leider ist das Spiel nicht gut spielbar mit desaktivierter Intelkarte und mit aktivierter Intelkarte stürzt das Spiel weiterhin ab.

mit Kompabilitätsmodus (XP) hab ich regelmässig nen hellblauen BIldschirm mit Spielmusik, das passiert mir immer wenn ich von See in den Stadtmodus wechsele.... habe ich unter win8.1 seltener festgestellt.

werde jetzt erstmal das Spiel desinstallieren, danach die Intelkarte desaktivieren und eine Neuinstallation des Spiels machen und schauen ob sich das Spiel dann besser ohne Intelkarte spielen lässt oder nicht.

ich melde mich wieder, wenn ich das getestet hab.

Daan Hugo

Kaufmann

  • »Daan Hugo« ist männlich

Beiträge: 208

Dabei seit: 28. Juni 2011

Wohnort: GMS-HQ

  • Private Nachricht senden

18

Donnerstag, 23. Juli 2015, 17:07

Hi!

Das mit dem nVidia Controlcenter (oder wie es heißt) klingt sehr komisch. Dein Grafikkartentreiber ist auch nicht mehr der jüngste. Ich würde empfehlen, diesen mal zu updaten und es anschließend erneut zu versuchen.
Evtl. kann dir auch dieser Thread helfen: http://forum.kalypsomedia.com/showthread.php?tid=6011

Beste Grüße,
Daan

hase09127

Schniggenfahrer

  • »hase09127« ist der Autor dieses Themas

Beiträge: 36

Dabei seit: 21. Juli 2015

Wohnort: Frankreich

  • Private Nachricht senden

19

Donnerstag, 23. Juli 2015, 22:50

hallo Daan,

ja find ich auch komisch, dass wenn die Intelkarte desaktiviert ist, ich nicht mehr in die NVIDIA 3D Optionen komme ... mit dem Treiber hab ich auch schon versucht, nur irgendwie will der den nicht updaten, der sagt mir jedes Mal, dass meiner auf dem neuesten Stand sei (17/06/2015) ... :( ich werde mal versuchen die neueste (22/06/2015) direkt von NVIDIA zu laden... <== der Treiberinstaller von NVIDIA sagt dass meine Version die neueste ist, ich versteh bald nur noch Bahnhof :crazy:

heute hab ich bis jetzt noch keinen Absturz gehabt - spielte jetzt gerade so 2,5 Stunden... vielleicht habe ich ja Glück und irgendetwas hat doch mehr oder weniger funktionniert ... (die Intelkarte ist zwar aktiviert aber ohne ist das Spiel nicht spielbar - Grafik total komisch und wenn ich irgendetwas machen will, dauert es eine Weile bis das Spiel reagiert)

mal schauen ob ich vielleicht dank eurer Vorschläge Glück habe und jetzt endlich richtig das Spiel geniessen kann.

(da fällt mir ein, dass ich P2 Gold - bzw. P3 (französische P2 Gold Version) auch noch nicht mit diesem PC getestet habe, dass wird aber erstmal warten)

Daan Hugo

Kaufmann

  • »Daan Hugo« ist männlich

Beiträge: 208

Dabei seit: 28. Juni 2011

Wohnort: GMS-HQ

  • Private Nachricht senden

20

Freitag, 24. Juli 2015, 10:27

Hi!

Den Treiber von der Herstellerseite zu holen würde ich dringend empfehlen, da ich des Öfteren bereits davon gehört habe, dass installierte Updater nicht immer korrekt funktionieren. Laut DxDiag ist dein Treiber jedenfalls vom Januar. Wie genau es auf deiner Maschine funktioniert kann ich zwar aus dem Stegreif nicht sagen, aber versuche mal die Intel-Karte aktiv zu lassen, aber das Spiel zur Verwendung der nVidia-Karte zu zwingen. Zudem könnte man noch der Anwendung noch einen Kompatibilitätsmodus zuweisen (einfach mal durchtesten, ob sich davon einer besser eignet).

Beste Grüße,
Daan