Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen im Patrizierforum. Falls dies Dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird Dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest Du Dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um Dich zu registrieren oder informiere Dich ausführlich über den Registrierungsvorgang. Falls Du Dich bereits zu einem früheren Zeitpunkt registriert hast, kannst Du Dich hier anmelden.

Tobi-D

Schniggenfahrer

  • »Tobi-D« ist männlich
  • »Tobi-D« ist der Autor dieses Themas

Beiträge: 34

Dabei seit: 28. Juli 2010

Wohnort: Nahe Hannover

  • Private Nachricht senden

1

Donnerstag, 5. August 2010, 20:08

Patrizier 2 - Problem unter Win 7

So läuft alles super abermacht das spiel oder so mucken.
und zwar
1. Wenn ein Pirat einen von uns Angreift (wir steuern die Seeschlachten nie selbst)macht er auf einmal langsam wenn man dann in der Option schaut steht Spielgeschwindigkeit auf normal
2. Wenn einer von uns auf die Kirche Geht stürzt das Spiel ab
so ich glaube das wars Erstmal
Liebe Grüße Tobi-D

P.S. Habe nur neues Thema gemacht weil das spiel nun nur am mucken ist
Lieber heimlich schlau als unheimlich blöd

Nagus Zek

Moderator

  • »Nagus Zek« ist männlich

Beiträge: 975

Dabei seit: 30. April 2008

Wohnort: Bendorf

  • Private Nachricht senden

2

Donnerstag, 5. August 2010, 23:34

Die Sache mit den Seeschlachten ist ein typisches Problem mit mehrkern-Prozessoren.
So schaltet man die zusaetzlichen Kerne ab. Es sollte fuer P2 nur ein Kern aktiv sein.

Das mit der Kirche ist auch bekannt. Von einer genauen Problemloesung weis ich allerdings noch nicht viel. Es scheint so zu sein, dass es bei manchen Leuten zu Abstuertzen kommt und bei manchen nicht.
Da die Kirche aber nicht so wichtig ist, kann man es auch ignorieren.

Preussenhusar

Fernkaufmann

  • »Preussenhusar« ist männlich

Beiträge: 448

Dabei seit: 14. Dezember 2007

Wohnort: Deutschland

  • Private Nachricht senden

3

Freitag, 6. August 2010, 08:41

Das mit der Kirche habe ich auch zuweilen (Vista)

Ich gehe ins Bad, dann in die Kirche - Absturz.

Mittlerweile gehe ich nach dem Bad erst ins Kontor (persönliches),
dann in die Kirche - das geht ...

PH

Tobi-D

Schniggenfahrer

  • »Tobi-D« ist männlich
  • »Tobi-D« ist der Autor dieses Themas

Beiträge: 34

Dabei seit: 28. Juli 2010

Wohnort: Nahe Hannover

  • Private Nachricht senden

4

Samstag, 7. August 2010, 20:48

vielen dank jetzt --->funktioniert<---(keine Ahnung wie man das schreibt) wieder alles
Gruß Tobi-D
Lieber heimlich schlau als unheimlich blöd

beetdigger

Krämer

Beiträge: 5

Dabei seit: 22. September 2009

  • Private Nachricht senden

5

Samstag, 4. September 2010, 20:46

Alle Tipps gelesen und ausgeführt, schwarzer Bildschirm bleibt

Hallo liebe Gemeinde,

ein tolles Forum habt ihr hier. Ich lese schon eine ganze Weile mit und finde insbesondere die neue Tippsammlung als sehr gelungen.

Jetzt habe ich allerdings folgendes Problem: Ich mag P2 unter Windows 7 Home Premium 64bit installieren und spielen.
Nach allerlei möglicher Einstellungen kann ich Patrizier 2.exe mit /norescheck und/oder /nointro starten. Bei norescheck sehe ich das Intro, danach bekomme ich einen schwarzen Bildschirm mit Hintergrundmusik. Binkplay.exe kann ich im Taskmanager abschalten. Lande aber weiterhin auf dem schwarzen Bildschirm. Wenn ich nointro ergänze, sehe ich das Intro nicht, kann aber im Taskmanager Binkplay.exe nicht finden und abschalten.
Zudem taucht in beiden Varianten im Taskmanager bei Anwendungen der Task SGL auf. Mit Doppelklick erhalte ich die Meldung Set Display Mode Failed. Wenn ich SGL dann beende erhalte ich die Meldung The current resolution and color depth you selected is invalid. Nothing can be displayed.

Was kann ich nun tun?
Ich habe Patrizier 2 Gold sowohl aus dem Action und Strategiepack von Green Pepper, als auch von der P4 DVD installiert. Vorsichtshalber habe ich auch sämtliche P2 Gold Dateien auf die Festplatte kopiert und von da aus installiert. Umbenennen der Intro Datei hat ebenfalls nichts gebracht. Kompatibilitätsmodus XP Servicepack 2 und 3 habe ich schon versucht.

Auch die Variante Datenausführungsverhinderung schlug fehl:
Start ---> Systemsteuerung ---> System und Sicherheit --->
System ---> Erweiterte Einstellungen ---> dann bei Leistung auf
Einstellungen gehen und dann auf den Reiter
"Dateiausführungsverhinderung" wechseln. Dort den zweiten Punkt
aktivieren "Dateiausführungsverhinderung für alle Programme und Dienste
mit Ausnahme der ausgewählten einschalten". Dann bei "Hinzufügen" die
Patrizier2.exe im Installationsverzeichnis hinzufügen.

Jetzt bin endgültig ratlos? Vielleicht könnt ihr mir ja weiterhelfen, ich würde mich über jegliche Unterstützung freuen.

Gruß

beetdigger

Dorimil

Eldermann

  • »Dorimil« ist männlich

Beiträge: 3 227

Dabei seit: 25. Juli 2005

Wohnort: Speckgürtel von Hamburg

  • Private Nachricht senden

6

Samstag, 4. September 2010, 21:34

öhm...ja...ich frag mal ganz blöd...

Den Grafikcheck hast Du aber gemacht?

Zumindest die Version von der P4 DVD sollte auf Win7 laufen. Bei den alten Versionen würde ich nicht dafür garantieren. Es sei denn sie ist aus nem Game-Magazin, die sind modifiziert...
Dorimil

Lebe jeden Tag, als wäre es Dein letzter!

beetdigger

Krämer

Beiträge: 5

Dabei seit: 22. September 2009

  • Private Nachricht senden

7

Sonntag, 5. September 2010, 01:09

Der Grafikcheck ist nicht durchführbar. Wenn ich testen wähle, erhalte ich die Meldung MFC-Anwendung P2Setup funktioniert nicht mehr.
Hab es schon mit einer Ausnahme in der Datenausführungsverhinderung versucht und im Kompatibilitätsmodus Windows XP (Service Pack 2).

**ratlos**

8

Sonntag, 5. September 2010, 19:14

Welche Auflösungen unterstützt denn Rechner/Graka? Oder allgemein eine Beschreibung deines Systems?

Funktionierte es vorher schon einmal? Was hast du seitdem getan?

Scheinbar funktioniert bei dir das Umschalten der Auflösung nicht korrekt. Der SGL-Task ist mir im Moment noch ein Rätsel, aber das klärt sich noch.
Der Weg durch die Mitte ist immer der beste. (Zentrallager/Sternsystem)

beetdigger

Krämer

Beiträge: 5

Dabei seit: 22. September 2009

  • Private Nachricht senden

9

Sonntag, 5. September 2010, 23:40

Hallo Krämer von nebenan,

nach der Desktopeinstellungsliste werden Auflösungen von 800 x 600 bis 1920 x 1080 unterstützt. Also auch die im Spiel möglichen Auflösungen von 800 x 600, 1024 x 768 und 1280 x 1024. Die Grafikkarte ist eine ATI Radeon HD 5970.

Microsoft Windows 7 Home Premium
x64 basierter PC
Intel Core i7 CPU 860 @ 2,.80GHz, 4 Kerne
8GB RAM

Ich habe das Spiel unter Windows 7 noch nicht zum Leben erwecken können.

Vineta

Kaufmann

Beiträge: 205

Dabei seit: 16. Januar 2007

  • Private Nachricht senden

10

Montag, 6. September 2010, 21:09

mein Win7 mag P2

@beetdigger

Win7 64 Home Premium + P2 von der CD die von Jahren mal bei Computerbild Spiele dabei war installiert, vertragen sich seit Anfang an grundsätzlich prima, bis auf das Eldermannvideo aber das ist ein Thema für sich. An Win7 selbst allein liegt das wohl nicht.
-
Ich habe ein Aldi Notebook Medion ca. 6 Monate alt, Prozessor 2,27 GHz, 4 GB Ram, Grafik Gforce 310M - also einfacher als Deine Hardware. Vielleicht ist die evtl. doch gerade eine Stufe zu gut für ein 10 Jahre altes Spiel (?)

Wünsche ich könnte Dir etwas konstruktiveres sagen.... :(

meint Vineta

Dorimil

Eldermann

  • »Dorimil« ist männlich

Beiträge: 3 227

Dabei seit: 25. Juli 2005

Wohnort: Speckgürtel von Hamburg

  • Private Nachricht senden

11

Dienstag, 7. September 2010, 10:33

Die Versionen aus Game-Magazinen sind modifiziert. Sprich die haben in der Regel einen "No-CD-Patch" an Bord und ein eventuell noch vorhandener Kopierschutz wurde entfernt. Vielleicht liegt darin das Problem bei normalen Versionen.

Konstruktiveres kann ich leider auch nich beisteuern, da ich keine Möglichkeit habe unter Win7 zu testen. Bin Vista-Nutzer (und tatsächlich zufrieden! :eek2: )
Dorimil

Lebe jeden Tag, als wäre es Dein letzter!

beetdigger

Krämer

Beiträge: 5

Dabei seit: 22. September 2009

  • Private Nachricht senden

12

Sonntag, 12. September 2010, 18:00

geht doch

Bei mir war es wohl ein Treiberproblem. Mit Catalyst 10.7, abgeschaltetem Intro und inaktiven Hardwareblitting läuft es jetzt.
*freu*